PyWart (Terminolgy): "Class"

Chris Angelico rosuav at gmail.com
Mon Jan 14 08:10:10 CET 2013


On Mon, Jan 14, 2013 at 5:46 PM, Rick Johnson
<rantingrickjohnson at gmail.com> wrote:
> Dear language designers: Stop propagating such foolish terminology! End the infection of "class" in all source code, docs, and daily conversation. Be more consistent and logical. Resist temptation to use poor terminology simply because other languages have done so before you. Grow a pair already!

Absolutely. We should learn from Lars Pensjö and start referring to
"blueprint objects" and "clones". Or take the updated version and call
them "programs" and "objects". I'm sure that'll make a huge amount
more sense than using the terms that millions of programmers already
understand.

Alternatively, we could take the Humpty Dumpty approach and assign
meanings to names arbitrarily. But wait till Saturday night when they
come for their wages.

ChrisA



More information about the Python-list mailing list