Galry, a high-performance interactive visualization package in Python

Terry Reedy tjreedy at udel.edu
Tue Jan 29 20:52:11 CET 2013


On 1/29/2013 1:23 PM, Cyrille Rossant wrote:

> The goal of this beta pre-release is to ensure that Galry can work on
> the widest possible range of systems and graphics cards (OpenGL v2+ is
> required).
 > <http://rossant.github.com/galry/>

 From that site:
"Mandatory dependencies include Python 2.7,"

For a new, still-beta package, this is somewhat sad. 2.7 is 3.5 years 
old and has only 1.5 years of semi-normal maintainance left. It will be 
more like 1 year when you get to your final release.

If you are not supporting anything before 2.7, it should not be hard to 
make your python code also support 3.x. Use the future imports for print 
and unicode. Others have written more guidelines.

"Numpy, either PyQt4 or PySide, PyOpenGL, matplotlib"

These all support 3.2,3.3 (PyOpenGl says 'experimental').

-- 
Terry Jan Reedy





More information about the Python-list mailing list