Why is CPython 2.5 a dependency for Jython 2.5?

Chris Angelico rosuav at gmail.com
Wed Jul 3 16:07:15 CEST 2013


On Wed, Jul 3, 2013 at 10:55 PM, rusi <rustompmody at gmail.com> wrote:
> On Wednesday, July 3, 2013 5:52:12 PM UTC+5:30, Steven D'Aprano wrote:
>> I'm running a box with Debian squeeze, and I just ran:
>> sudo aptitude install jython
>> which ended up installing Python 2.5:
>
> BTW trying to install jython out here gave me this list
> (which does not seem to have this dependency):
>
> $ sudo aptitude install jython
> The following NEW packages will be installed:
> antlr3{a} ca-certificates-java{a} default-jdk{a} default-jre{a}
>   default-jre-headless{a} icedtea-6-jre-cacao{a} icedtea-6-jre-jamvm{a}
>   icedtea-netx{a} icedtea-netx-common{a} jython libantlr-java{a}
>   libasm4-java{a} libatk-wrapper-java{a} libatk-wrapper-java-jni{a}
>   libconstantine-java{a} libguava-java{a} libjaffl-java{a} libjffi-java{a}
>   libjffi-jni{a} libjnr-netdb-java{a} libjnr-posix-java{a}
>   libjnr-x86asm-java{a} libjsr305-java{a} liblivetribe-jsr223-java{a}
>   libreadline-java{a} libstringtemplate-java{a} openjdk-6-jdk{a}
>   openjdk-6-jre{a} openjdk-6-jre-headless{a} openjdk-6-jre-lib{a}
>   tzdata-java{a}
>
> $ cat /etc/debian_version
> jessie/sid
>
> [And python2.5 is not installed]

Python 2.5 may not be installed (it's no longer available on Wheezy,
so it wouldn't surprise me if Jessie also doesn't have it), but quite
possibly there's another Python available. On my Wheezy system, I
already have Python 2.7 installed, and apt-getting jython doesn't ask
to install any more Pythons; but 'apt-cache show jython' doesn't
suggest anything that'd be pulling in Python, and I don't have a handy
way to poke around and find what would be pulling that in.

ChrisA



More information about the Python-list mailing list