[ANN] pyparsing 2.0.1 released - compatible with Python 2.6 and later

Paul McGuire ptmcg at austin.rr.com
Sat Jul 20 23:30:14 CEST 2013


In my releasing of Pyparsing 1.5.7/2.0.0 last November, I started to split supported Python versions: 2.x to the Pyparsing 1.5.x track, and 3.x to the Pyparsing 2.x track. Unfortunately, this caused a fair bit of pain for many current users of Python 2.6 and 2.7 (especially those using libs dependent on pyparsing), as the default installed pyparsing version using easy_install or pip would be the incompatible-to-them pyparsing 2.0.0.

I hope I have rectified (or at least improved) this situation with the latest release of pyparsing 2.0.1. Version 2.0.1 takes advantage of the cross-major-version compatibility that was planned into Python, wherein many of the new features of Python 3.x were made available in Python 2.6 and 2.7. By avoiding the one usage of ‘nonlocal’ (a Python 3.x feature not available in any Python 2.x release), I’ve been able to release pyparsing 2.0.1 in a form that will work for all those using Python 2.6 and later. (If you are stuck on version 2.5 or earlier of Python, then you still have to explicitly download the 1.5.7 version of pyparsing.)

This release also includes a bugfix to the new ‘<<=’ operator, so that ‘<<’ for attachment of parser definitions to Forward instances can be deprecated in favor of ‘<<=’.

Hopefully, most current users using pip and easy_install can now just install pyparsing 2.0.1, and it will be sufficiently version-aware to function under all Pythons 2.6 and later.

Thanks for your continued support and interest in pyparsing!

-- Paul McGuire




More information about the Python-list mailing list