"No symbol" error using pystack gdb macro

dieter dieter at handshake.de
Sat Mar 2 08:08:31 CET 2013


debby at josesmex.com writes:

> I'm relatively new to Python, running Python 3.3 on FreeBSD
>
> I have a process which has started to spike CPU usage.  I'm trying to find out what it's doing.
>
> I tried the "pystack" macro suggested here:
>
> http://stackoverflow.com/questions/132058/showing-the-stack-trace-from-a-running-python-application/147114#147114
>
> I got the gdbinit macro from:
>
> http://svn.python.org/projects/python/trunk/Misc/gdbinit 
>
> When I attach gdb, it tells me it is loading symbols from python3.3m
>
> However when I run pystack I get:
>
> No symbol "PyStringObject" in current context.
>
> Do I need an updated version of the gdb macro for Python3.3?

Many system installed Python versions (all, I have seen so far)
are "stripped", i.e. they lack debugging information.
Such information is necessary in order to use the gdb macros
effectively.

I suggest you install and compile your Python yourself.
Likely, the generated Python will have debugging symbols without
(manual) intervention. If not, the installation instructions should
tell you how to get a Python with debugging symbols.




More information about the Python-list mailing list