How to define "exec" method on a class object? Get syntax error due to built in command

Chris Angelico rosuav at gmail.com
Wed Mar 27 02:27:17 CET 2013


On Wed, Mar 27, 2013 at 10:19 AM, Steven D'Aprano
<steve+comp.lang.python at pearwood.info> wrote:
> On Wed, 27 Mar 2013 06:39:24 +1100, Chris Angelico wrote:
>> I strongly recommend upgrading. 2.3.4 dates back to 2004, that's roughly
>> a decade of bug fixes and feature enhancements behind the times.
>
> Python 2.3 is still supported by Red Hat, at least if you have paid for
> extended support. In principle at least, Red Hat will be providing
> security fixes for 2.3.

Oh, I thought they only supported 2.4. My bad. Still, there's ten
years of feature improvements, even if not security patches.

ChrisA



More information about the Python-list mailing list