Python 3.2.3 and my blank page

Νίκος Γκρ33κ nikos.gr33k at gmail.com
Sun Mar 31 22:08:59 CEST 2013


Τη Κυριακή, 31 Μαρτίου 2013 10:46:57 μ.μ. UTC+3, ο χρήστης ru... at yahoo.com έγραψε:
> On 03/31/2013 01:12 PM, Νίκος Γκρ33κ wrote:
> 
> > Firsly, thank you for your willing to help me. i wrote, uploaded an
> 
> > chmoded test.py and you can see the cgi enviromental table here:
> 
> > http://superhost.gr/cgi-bin/test.py All values seem okey, so it
> 
> > really isnt somehting wrong with the cgi enviroment. Also i chnagen
> 
> > the host line to what you suggestes so interactive prompts will not
> 
> > give errors. Please take a look the values to see if something not
> 
> > look  ok and i 'am about to create another trest script to check if i
> 
> > can pefrom a simple mysql query with python 3.2.3 just to make sure
> 
> > the MySQLdb connector work ok with 3.x
> 
> 
> 
> I didn't mean that there was anything *wrong* with your cgi 
> 
> environment, only that it is *different* than your interactive 
> 
> environment.
> 
> 
> 
> It is easier to debug code in an interactive environment than a 
> 
> cgi one so you want to do as much debugging interactively as possible,.
> 
> But because the environments are different your code will behave 
> 
> differently.  Knowing what is different between the two environments
> 
> will help you know if an error is due to a real problem in your
> 
> code, or is just due to the different environment.  And it will
> 
> help you setup your interactive environment to be as close as 
> 
> possible to the cgi one.


But i look the code and run python via interactive prompt and it says it has no error.

So i don't have a clue on what i still need to try since i get no error via cmd or via browser(blank page)



More information about the Python-list mailing list