Help Python 3.3

Zachary Ware zachary.ware+pylist at gmail.com
Fri Nov 1 14:33:24 CET 2013


On Fri, Nov 1, 2013 at 8:20 AM,  <radu.bortoi at gmail.com> wrote:
>
> Hi all,
>
> error: Setup script exited with error: Unable to find vcvarsall.bat
>
> Visual C++ Express installed.

Which version?  Python 3.3 requires Visual C++ 2010 (10.0).

> the key HKEY_LOCAL_MACHINE\Software\Microsoft\VCExpress\9.0\Setup\VC\ProductDir

This looks like Visual C++ 2008 (9.0).

> is present and point to the vcvarsall.bat location.
> PC restarted(just for fun).
>
> what is wrong??

I would have to guess that you've got the wrong version of Visual C++.
 You can install both 2008 and 2010 in parallel, if you need 2008 for
something else.

Hope this helps,

--
Zach

PS: In the future, it is very helpful to say which OS you're using
since Python is usable on so many different platforms.  In this case
it's pretty obvious that you're using Windows, but there are still
differences between Windows versions that mean knowing the version
makes support easier.



More information about the Python-list mailing list