Python 3.3 and Pygame 19.2a install problems

edvogel56 at gmail.com edvogel56 at gmail.com
Mon Feb 3 04:04:48 CET 2014


On Sunday, February 2, 2014 8:06:11 PM UTC-6, edvo... at gmail.com wrote:
> Hi,
> 
>   I am putting together tutorials to accompany "Invent Your Own Computer Games with Python" for a volunteer gig. I installed Python 3.3 and Pygame 19.2a on an XP machine and it works fine.  However the install on my Win7 (Home Edition)HP notebook is not working.
> 
> 
> 
> While running python code from Idle that uses Pygames I get this message:
> 
> 
> 
> Traceback (most recent call last):
> 
>   File "C:\Users\Ed\Documents\SOMA\Minecraft and Python\inventwithpython_src\dodger.py", line 1, in <module>
> 
>     import pygame, random, sys
> 
>   File "C:\Python33\lib\site-packages\pygame\__init__.py", line 95, in <module>
> 
>     from pygame.base import *
> 
> ImportError: DLL load failed: The specified module could not be found.
> 
> 
> 
> 
> 
> I am looking at the computers and installed directories side by side and I don't see anything "missing."  That being said there is a base.pyd file but not a base.dll.  I understand .pyd files are a type of dll.  Could there be something about Win7 doesn't like about that naming convention?
> 
> 
> 
> Please advise.
> 
> 
> 
> Thanks!
> 
> 
> 
> EdV
Found the answer here:
http://www.reddit.com/r/inventwithpython/comments/1dzl8m/when_importing_pygame_i_get_importerror_dll_load/

Questions but no big deal - 
1. Why doesn't pygame.org have the most recent install files compatible with the most recent python?  I ended up finding them here:
http://www.lfd.uci.edu/~gohlke/pythonlibs/

2. Interesting that "3.2" pygames works with "3.3" python on my XP but the Win 7 required the "3.3" pygames.  Thoughts?

Thanks again.

EdV



More information about the Python-list mailing list