Problems compiling Python 3.4 on Ubuntu

Chris Angelico rosuav at gmail.com
Mon Feb 3 20:11:03 CET 2014


On Tue, Feb 4, 2014 at 6:05 AM, Zachary Ware
<zachary.ware+pylist at gmail.com> wrote:
> On Mon, Feb 3, 2014 at 12:48 PM, Chris Angelico <rosuav at gmail.com> wrote:
>> On Tue, Feb 4, 2014 at 2:50 AM, Christian Heimes <christian at python.org> wrote:
>>> On 03.02.2014 16:14, Ram Rachum wrote:
>>>> Worked! Thanks Ervin!
>>>
>>>    $ sudo apt-get build-dep python3.3
>>>
>>> will install everything you need to compile Python 3.4 on Debian and
>>> Ubuntu. Good luck! :)
>>
>> Technically that gets everything you need to compile Python 3.3...
>> wasn't there one more library needed for 3.4? It's still an excellent
>> way to get nearly everything, though.
>
> I think you're thinking of 3.2 -> 3.3.  3.3 added the lzma module,
> which requires lzma-dev.  I think 3.4 has the same requirements as
> 3.3.

Ah, that would be it, thanks. I just remembered I'd recently used
build-dep across versions and had to get something involving data
compression. Went digging for stuff starting with 'z', but missed this
because, well, it doesn't start with 'z' :) Thanks.

ChrisA



More information about the Python-list mailing list