Python 3.3 and Pygame 19.2a install problems

Terry Reedy tjreedy at udel.edu
Mon Feb 3 22:42:21 CET 2014


On 2/3/2014 1:55 PM, MRAB wrote:
> On 2014-02-03 06:43, Terry Reedy wrote:

>> It is possible that the VC++2010 runtime does not work with XP, but
>> requires Vista+ and that the Microsoft installer installs the older
>> VC++2008 runtime on XP even when installing 3.3. If you install for a
>> single user, the vcxxxxx.dll is in the python directory or subdirectory.
>> For all-user installs, it is in one of the windows/systemxx directories.
>> But this is just a guess.

The names are msvcxxxx.dll and specifically msvcrtxxx.dll

> I've used Visual C++ Express 2010 on XP Pro without any problem.

The question I was trying to answer is why code compiled with VC2010 
would act differently (work with 3.2 or not) on xp and win7. When 
running of win7, the code can use system calls that did not exist in xp. 
When running on xp, the code must do something different (probably 
slower, if not stop). Exactly where the different paths reside is not so 
important.

-- 
Terry Jan Reedy




More information about the Python-list mailing list