Latest Python 3.4 in the source repo is broken?

Ethan Furman ethan at stoneleaf.us
Tue Feb 4 18:01:15 CET 2014


On 02/04/2014 07:45 AM, Steven D'Aprano wrote:
> Before I bother Python-Dev with this, can anyone else confirm that
> building Python 3.4 from source using the latest version in the source
> repository fails?

This is the check-out I'm using:

ethan at media:~/source/python/cpython$ hg parent
----------------------------------------------------------------------------
rev:	88961:7d0a4f89c6ce
branch:	default
tag:	tip
user:	Vinay Sajip <vinay_sajip at yahoo.co.uk>
date:	2014-02-04 16:42 +0000
desc:	Closes #20509: Merged documentation update from 3.3.
----------------------------------------------------------------------------

These are the settings I always use to make sure I have no weird problems between check-outs:

ethan at media:~/source/python/cpython$ make distclean && ./configure --with-pydebug && make -j3
..
..
..
Python build finished successfully!
The necessary bits to build these optional modules were not found:
_gdbm                 _lzma
To find the necessary bits, look in setup.py in detect_modules() for the module's name.

running build_scripts
creating build/scripts-3.4
copying and adjusting /home/ethan/source/python/cpython/Tools/scripts/pydoc3 -> build/scripts-3.4
copying and adjusting /home/ethan/source/python/cpython/Tools/scripts/idle3 -> build/scripts-3.4
copying and adjusting /home/ethan/source/python/cpython/Tools/scripts/2to3 -> build/scripts-3.4
copying and adjusting /home/ethan/source/python/cpython/Tools/scripts/pyvenv -> build/scripts-3.4
changing mode of build/scripts-3.4/pydoc3 from 664 to 775
changing mode of build/scripts-3.4/idle3 from 664 to 775
changing mode of build/scripts-3.4/2to3 from 664 to 775
changing mode of build/scripts-3.4/pyvenv from 664 to 775
renaming build/scripts-3.4/pydoc3 to build/scripts-3.4/pydoc3.4
renaming build/scripts-3.4/idle3 to build/scripts-3.4/idle3.4
renaming build/scripts-3.4/2to3 to build/scripts-3.4/2to3-3.4
renaming build/scripts-3.4/pyvenv to build/scripts-3.4/pyvenv-3.4


Hope this helps.

--
~Ethan~



More information about the Python-list mailing list