Pip doesn't install my scripts

Chris “Kwpolska” Warrick kwpolska at gmail.com
Sat Jul 19 11:44:19 CEST 2014


On Sat, Jul 19, 2014 at 9:19 AM, Yaşar Arabacı <yasar11732 at gmail.com> wrote:
> Hi,
>
> I am trying to package my file, but I am having problems with
> installing my Scripts. Here is my package:
> https://github.com/yasar11732/tklsystem
>
> Here is my package's PyPi page: https://pypi.python.org/pypi/TkLsystem
>
> The problem I face is that, when I run `python setup.py install` from
> my development directory, I see that script file is installed.
> However, if I run `pip install TkLsystem`, my script file is not
> copied to Scripts directory.
>
> What am I doing wrong here?
>
> --
> http://ysar.net/
> --
> https://mail.python.org/mailman/listinfo/python-list

Tons of things are wrong.

* SyntaxError: Non-ASCII character '\xc5' in file lsystem/__init__.py
on line 6, but no encoding declared; see
http://python.org/dev/peps/pep-0263/ for details
* you should not import your package in setup.py
* you are python 3-only for no real reason at all
* the zip on PyPI is for version 0.1.3.  It ignores the version 0.1-5,
because of the dash, which should not be used in names of stable
software
* and, most importantly, you’re doing things using ancient methods.
Upgrade your setup.py to use setuptools, and its entry points
mechanism.

I’ve sent a PR to fix all of your errors:
https://github.com/yasar11732/tklsystem/pull/1

-- 
Chris “Kwpolska” Warrick <http://chriswarrick.com/>
PGP: 5EAAEA16
stop html mail | always bottom-post | only UTF-8 makes sense



More information about the Python-list mailing list