Strange Error with pip install.

Bruce Whealton futurewavewebdevelopment at gmail.com
Sat Jul 26 01:39:48 CEST 2014


Hello,
      I am using Windows 8.1 (I do have a linux box setup with virtualbox also) and I've used python previously but now it is giving me problems whenever I try to install anything from PyPI using pip.  The error I get from the command line is 
"Cannot fetch index base URL http://pypi.python.org/simple/
Could not find any downloads that satisfy the requirement..."

I tried within the MinGW environment setup when I installed Git and was given Git Bash as a console.  I also installed Bitnami Django stack and even in that environment, I get that error.

I did some Google searches but I seem to only happen when people are trying to install Django.  For me it is happening with django and any other pypi installation with pip.  

Interestingly, as I started trying to get advice with this, in the django chat room - at the time I was trying to get django to work in my Windows environment, someone suggested Vagrant.  I started creating some boxes with Vagrant and Puppet, Chef or bash scripts.  I had problems with this inside a Windows command prompt.  So, I tried it under the MinGW environment I mentioned above, and half the time, when I run Vagrant up, it starts the environment but then it tries to connect using a public key authentication.  Sometimes it will just give up and let me run vagrant ssh or use putty.  Other times it just times out.  

One idea I have is to import a VirtualBox "box" from Bitnami into VirtualBox, their Django stack.  

Does anyone have any suggestions about this problem I am having using pip install <somepackage> inside Windows (Windows 8, if that matters)?

Thanks in advance,
Bruce



More information about the Python-list mailing list