Unable to find ssh library supporting python 3.1

Chris “Kwpolska” Warrick kwpolska at gmail.com
Wed Jul 30 14:28:18 CEST 2014


On Wed, Jul 30, 2014 at 1:49 PM, Chirag Dhyani <chiragdhyani at gmail.com> wrote:
> Hi,
>
> Could you suggest me ssh library supporting python 3.1, to a surprise I
> checked pramiko, fabric, etc etc and no one does. even workaround with
> plumbum but not helpful. We have a project entirely on python 3.1 and now we
> are stuck with ssh.
>
> Please help
>
> Thank you
> ~Chi

Python 3.1.0 celebrated its fifth birthday on Sunday.  You should not
be using software that old.  There is no real reason to do so,
especially because modern versions of the 3.x series are generally
backwards compatible with each other.

Instead, upgrade to the most recent version, 3.4.1, which is happily
supported by Paramiko.  Many Python 3-compatible libraries
dropped/never had support for 3.0—3.2 due to
<http://legacy.python.org/dev/peps/pep-0414/>, which makes porting
between Python 2 and 3 much easier.

-- 
Chris “Kwpolska” Warrick <http://chriswarrick.com/>
PGP: 5EAAEA16
stop html mail | always bottom-post | only UTF-8 makes sense



More information about the Python-list mailing list