CentOS 6.5 / SPEC file

Devin delldudedevin at gmail.com
Thu Mar 27 21:02:49 CET 2014


I have been trying to compile an RPM manually using the SPEC file that is
contained in the source tarball from Python.org's website. I have tried
multiple versions and they all seem to fail. I have tried the latest 3.4.0
release, 3.3.5 release, and 3.2.5 release. It appears the SPEC file
contained in the Misc/RPM directory is broken.

I am seeing the error:

+ '[' '!' -z 2.6 ']'
+ cd /builddir/build/BUILDROOT/python2.6-3.3.5-1pydotorg.x86_64/usr/bin
+ mv pydoc pydoc.old
mv: cannot stat `pydoc': No such file or directory
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.yqWO6C (%install)
    line 71: buildprereq is deprecated: BuildPrereq: expat-devel
    line 72: buildprereq is deprecated: BuildPrereq: db4-devel
    line 73: buildprereq is deprecated: BuildPrereq: gdbm-devel
    line 74: buildprereq is deprecated: BuildPrereq: sqlite-devel
    line 91: prereq is deprecated: Prereq: python2.6 = %{PACKAGE_VERSION}
    line 122: prereq is deprecated: Prereq: python2.6 =
%{PACKAGE_VERSION}-1pydotorg
    Bad exit status from /var/tmp/rpm-tmp.yqWO6C (%install)

It seems to give me this error regardless of what version of Python I am
trying. Is there a good website that contains maybe a more correct version
of the SPEC file for CentOS 6.x? Any help would be greatly appreciated.

Devin Acosta
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-list/attachments/20140327/e1606bc2/attachment.html>


More information about the Python-list mailing list