bdist_rpm with --requires and version

Chris Angelico rosuav at gmail.com
Sat Nov 8 07:46:56 CET 2014


On Sat, Nov 8, 2014 at 2:18 AM,  <thomas.lehmann at teamaol.com> wrote:
> But how to? ...
>   python setup.py bdist_rpm --requires=another-package>=2.1
>
> Of course this will generate a "=2.1" file which is
> of course not wanted.

What shell are you on? On POSIX shells, just quote or escape the
relevant part. On Windows... I'm not sure. Depends whether you have
cmd.exe, powershell, or something else, and I don't know any of them
well enough to advise. But try putting the whole argument in quotes.

ChrisA



More information about the Python-list mailing list