ssl error with the python mac binary

Paul Wiseman poalman at gmail.com
Mon Nov 10 12:05:10 CET 2014


Hey,

I've been using the latest mac ppc/i386 binaries from python.org
(https://www.python.org/ftp/python/2.7.8/python-2.7.8-macosx10.5.dmg).
>From what I can tell this version is linked against a pretty old
version of OpenSSL (OpenSSL 0.9.7l 28 Sep 2006) which doesn't seem to
be able to handle new sha-256 certificates.

For example I'm unable to use pip (I guess the certificate was updated recently)

Searching for gnureadline
Reading https://pypi.python.org/simple/gnureadline/
Download error on https://pypi.python.org/simple/gnureadline/: [Errno
1] _ssl.c:510: error:0D0890A1:asn1 encoding
routines:ASN1_verify:unknown message digest algorithm -- Some packages
may not be found!

Am I right in thinking this is an issue with the build of python
itself? Is there a way I can upgrade the version of OpenSSL linked
with python- or force the python build to look elsewhere for the
library? Or will I have to build my own from source?

Thanks!

Paul



More information about the Python-list mailing list