Question about installing python and modules on Red Hat Linux 6

Michael Torrie torriem at gmail.com
Sat Nov 15 18:02:09 CET 2014


On 11/14/2014 08:01 PM, pythonista wrote:
> Can anyone provide me with insight as to the scope what the problem could have been?

Well the fact is that RHEL 6 uses Python 2.6 as a core system package.
Many system utilities depend on it, so it cannot be replaced with a
newer version.  You must install the newer version alongside the old
version.  This can be easily accomplished with Redhat's Software
Collections system.  I have Python 2.7 and 3.4 installed on my RHEL6 box
with this machanism.



More information about the Python-list mailing list