Issues installing Python 2.7

billyfurlong at gmail.com billyfurlong at gmail.com
Wed Nov 26 18:09:30 CET 2014


Hi all,

Not a python user but I'm trying to upgrade python so I can install pip which is required for one of the apps that I'm installing.

I've tried to install using the below instructions, but when I type python I still get the old 2.4.3 version.  Oh Red Hat 5.8 is where I'm installing on.


yum groupinstall "development tools" -y     
yum install readline-devel openssl-devel gmp-devel ncurses-devel gdbm-devel \
glib-devel expat-devel libGL-devel tk tix gcc-c++ \ 
libX11-devel glibc-devel bzip2 tar tcl-devel tk-devel pkgconfig \
tix-devel bzip2-devel sqlite-devel autoconf db4-devel libffi-devel \
valgrind-devel -y    
mkdir tmp  
cd tmp  
wget http://python.org/ftp/python/2.7.5/Python-2.7.5.tgz  
tar xvfz Python-2.7.5.tgz  
cd Python-2.7.5

./configure --prefix=/opt/python2.7 --enable-shared

make

make altinstall

Add this to the bashrc
export PATH=$PATH:/opt/python2.7/bin/


Now the installation worked fine but shouldn't I see that it's using the correct version???

I also did try to run /opt/python2.7/bin/python2.7 and it give me this.

[root at wmy machine bin]# python2.7
python2.7: error while loading shared libraries: libpython2.7.so.1.0: cannot open shared object file: No such file or directory

Please help the newb.  He's frustrated.



More information about the Python-list mailing list