Suds Python 2.4.3 Proxy

Chris Angelico rosuav at gmail.com
Sun Nov 30 10:10:35 CET 2014


On Sun, Nov 30, 2014 at 2:01 AM, Jerry Rocteur <jerry.rocteur at gmail.com> wrote:
> This works GREAT on 2.7 but when I run it on 2.4 I get:
>
>   File "/usr/lib64/python2.4/urllib2.py", line 580, in proxy_open
>     if '@' in host:
> TypeError: iterable argument required

It might be worth looking at some actual 2.4 documentation.
Unfortunately that doesn't seem to be hosted on python.org any more
(though I might be wrong), so you'll want to look on your system
itself and find some docs.

Otherwise, why not simply install Python 2.7 on those systems? It can
happily coexist with the system 2.4.

ChrisA



More information about the Python-list mailing list