Which module I'm missing?

Igor Korot ikorot01 at gmail.com
Thu Sep 25 04:52:18 CEST 2014


Hi, ALL,
I got a suggestion to install eric for my developmental needs.
Unfortunately, it looks like my Linux distribution have a bug as
running eric throws an exception.

[code]
igor at IgorDellGentoo ~/plaso-build/liblnk-20140905 $ eric5
An unhandled exception occurred. Please report the problem
using the error reporting dialog or via email to
<eric5-bugs at eric-ide.python-projects.org>.
A log has been written to "/home/igor/.eric5/eric5_error.log".

Error information:
--------------------------------------------------------------------------------
2014-09-21, 07:56:26
--------------------------------------------------------------------------------
<class 'ImportError'>:
No module named 'DebugClients.Python3.coverage'
--------------------------------------------------------------------------------
  File "/usr/lib64/python3.3/site-packages/eric5/eric5.py", line 268,
in <module>
    main()
  File "/usr/lib64/python3.3/site-packages/eric5/eric5.py", line 245, in main
    from UI.UserInterface import UserInterface
  File "/usr/lib64/python3.3/site-packages/eric5/UI/UserInterface.py",
line 34, in <module>
    from QScintilla.MiniEditor import MiniEditor
  File "/usr/lib64/python3.3/site-packages/eric5/QScintilla/MiniEditor.py",
line 26, in <module>
    from .SearchReplaceWidget import SearchReplaceWidget
  File "/usr/lib64/python3.3/site-packages/eric5/QScintilla/SearchReplaceWidget.py",
line 16, in <module>
    from .Editor import Editor
  File "/usr/lib64/python3.3/site-packages/eric5/QScintilla/Editor.py",
line 35, in <module>
    from DataViews.PyCoverageDialog import PyCoverageDialog
  File "/usr/lib64/python3.3/site-packages/eric5/DataViews/PyCoverageDialog.py",
line 22, in <module>
    from DebugClients.Python3.coverage.misc import CoverageException

--------------------------------------------------------------------------------
Version Numbers:
  Python 3.3.3
  Qt 4.8.5
  PyQt4 4.10.3
  sip 4.15.3
  QScintilla 2.7.2
  WebKit 534.34
  eric5 5.3.6 (rev 1d360120e928)

Platform: linux
3.3.3 (default, May 29 2014, 03:55:37)
[GCC 4.7.3]
--------------------------------------------------------------------------------
Distribution Info:
  /etc/os-release
  NAME=Gentoo
  ID=gentoo
  PRETTY_NAME="Gentoo/Linux"
  ANSI_COLOR="1;32"
  HOME_URL="http://www.gentoo.org/"
  SUPPORT_URL="http://www.gentoo.org/main/en/support.xml"
  BUG_REPORT_URL="https://bugs.gentoo.org/"

  /etc/gentoo-release
  Gentoo Base System release 2.2
igor at IgorDellGentoo ~/plaso-build/liblnk-20140905 $ emerge -pv eric

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] dev-util/eric-5.3.6:5  USE="spell" LINGUAS="ru -cs
-de -en -es -fr -it -tr -zh_CN" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
igor at IgorDellGentoo ~/plaso-build/liblnk-20140905 $ eselect python list
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.3
[/code]

So my question is: which module I need to install?

Thank you.



More information about the Python-list mailing list