pypi submission?

Dave Hein jenesuispasdave at gmail.com
Tue Apr 7 03:02:37 CEST 2015


On Monday, April 6, 2015 at 5:19:29 PM UTC-5, Benjamin Schollnick wrote:
> Folks,
> 
> 
> I'm having issues with submitting to pypi.
> 
> 
> I can register and upload my package.
> 
> 
> 
> nerv:~ Benjamin$ pip search directory_caching
> Directory_Caching         - A Caching library for Directories & Files
> nerv:~ Benjamin$ 
> 
> 
> but, if you try to install it using pip:
> 
> 
> 
> pip install directory_caching
> Reading Profile from ~/dropbox/shellscripts/profile
> nerv:~ Benjamin$ pip install directory_caching
> Collecting directory-caching
>   Could not find any downloads that satisfy the requirement directory-caching
>   No distributions at all found for directory-caching
> 
> 

Try adding the "--pre" option. If your version number is an 'alpha' or 'pre' or 'rc' version (like 1.0a1 or 1.0rc4), then pip won't install it by default ... it will only install 'released' versions (like 1.0 or 1.0.1).

Adding the --pre option tells pip you actually do want the pre-release version. So:

pip install --pre directory-caching


>
[snip]

> 
> 		- Benjamin

--
Dave Hein




More information about the Python-list mailing list