installing matplotlib

Pippo adm2303.2304 at gmail.com
Mon Apr 13 21:33:55 CEST 2015


Hi guys,

I am trying to install matplotlib and I keep getting error:

Traceback (most recent call last):
  File "setup.py", line 155, in <module>
    result = package.check()
  File "/Users/sepidehghanavati/Desktop/Programs/python/matplotlib-1.4.3/setupext.py", line 961, in check
    min_version='2.3', version=version)
  File "/Users/sepidehghanavati/Desktop/Programs/python/matplotlib-1.4.3/setupext.py", line 445, in _check_for_pkg_config
    if (not is_min_version(version, min_version)):
  File "/Users/sepidehghanavati/Desktop/Programs/python/matplotlib-1.4.3/setupext.py", line 173, in is_min_version
    return found_version >= expected_version
  File "/Library/Frameworks/Python.framework/Versions/3.3/lib/python3.3/distutils/version.py", line 76, in __ge__
    c = self._cmp(other)
  File "/Library/Frameworks/Python.framework/Versions/3.3/lib/python3.3/distutils/version.py", line 343, in _cmp
    if self.version < other.version:
TypeError: unorderable types: str() < int()

any idea?



More information about the Python-list mailing list