installing matplotlib

Ned Deily nad at acm.org
Mon Apr 13 21:58:31 CEST 2015


In article <176d49d3-6ff8-4d35-b8ec-647f13250135 at googlegroups.com>,
 Pippo <adm2303.2304 at gmail.com> wrote:
> I am trying to install matplotlib and I keep getting error:
[...]
>   File 
>   "/Library/Frameworks/Python.framework/Versions/3.3/lib/python3.3/distutils/v
>   ersion.py", line 343, in _cmp
>     if self.version < other.version:
> TypeError: unorderable types: str() < int()
> 
> any idea?

If you are running on OS X 10.10 (Yosemite), try upgrading to a current 
Python 3.4.x.  3.3.x is no longer supported and was released long before 
Yosemite was.

http://bugs.python.org/issue21811

-- 
 Ned Deily,
 nad at acm.org




More information about the Python-list mailing list