Problem running Python 2.7 on Ubuntu 10.04

David Aldrich David.Aldrich at EMEA.NEC.COM
Mon Apr 20 17:31:17 CEST 2015


Hi

I wonder if someone could help me with this problem please?

On an Ubuntu 10.04 platform, I want to run the latest version of Meld, which is a Python program.

Ubuntu 10.04 runs Python 2.6 as standard.  Meld requires Python 2.7.  So I have installed Python 2.7 under /usr/local/bin and Python 2.7 runs ok there.

But when I try to run Meld I see:

-> /usr/local/bin/python2.7 ~/meld/bin/meld
Cannot import: GTK+
No module named gi

So I need to install the gtk package and do so in such a way that it is visible to /usr/local/bin/python2.7.

How would I do that please?

Best regards

David



Best regards

David

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/python-list/attachments/20150420/cfa484fb/attachment.html>


More information about the Python-list mailing list