Problem running Python 2.7 on Ubuntu 10.04

Dave Farrance DaveFarrance at OMiTTHiSyahooANDTHiS.co.uk
Mon Apr 20 19:25:07 CEST 2015


David Aldrich <David.Aldrich at EMEA.NEC.COM> wrote:

>Hi
>
>I wonder if someone could help me with this problem please?
>
>On an Ubuntu 10.04 platform, I want to run the latest version of Meld, which is a Python program.
>
>Ubuntu 10.04 runs Python 2.6 as standard.  Meld requires Python 2.7.  So I have installed Python 2.7 under /usr/local/bin and Python 2.7 runs ok there.
>
>But when I try to run Meld I see:
>
>-> /usr/local/bin/python2.7 ~/meld/bin/meld
>Cannot import: GTK+
>No module named gi

My understanding is that "gi" is GTk3 and I suspect that you're not
going to successfully install that on Ubuntu 10 which is a GTk2 distro.



More information about the Python-list mailing list