Question Installing latest Python

Steven D'Aprano steve+comp.lang.python at pearwood.info
Wed Apr 29 08:49:40 CEST 2015


On Wednesday 29 April 2015 16:13, Φώντας Λαδοπρακόπουλος wrote:

> Τη Τετάρτη, 29 Απριλίου 2015 - 8:57:25 π.μ. UTC+3, ο χρήστης Steven
> D'Aprano έγραψε:
> 
>> Okay, I googled that error message and I think I understand what is
>> failing, even though I don't understand why it is failing.
>> 
>> First, run this as root:
>> 
>> ldconfig
>> 
>> That will tell your system to cache any shared libraries it knows about.
>> yum is supposed to do that for you, but perhaps it didn't. Now try
>> running the python3 test above. Does it work? Then the problem is solved
>> and you can stop reading.
>> 
>> If you get the same error, then run this as root:
>> 
>> find /opt -name libpython3.3m.so.1.0
> 
> 
> Hello Steven,
> 
> I'am at that point, where the find outputed just 1 result.
> i run ldconfig but i still got the same error message.
> 
> Should i have done somethign with '/etc/ld.so.conf' althought it have
> returned just 1 result or that was for more results?


Run:

find /opt -name libpython3.3m.so.1.0

as root. If it returns NO results, you will have to run this instead:

find / -name libpython3.3m.so.1.0 2> /dev/null

But if it returns ONE result, take that result and extract the path. Say it 
returns:

/this/that/libpython3.3m.so.1.0


then the path you want is /this/that (without the / at the end). Edit 
/etc/ld.so.conf and add this line to the end:

/this/that

Save your changes, run ldconfig again, and hopefully python3 will now work.


If ldconfig gives you any errors, tell us what they are.



-- 
Steve




More information about the Python-list mailing list