Improper Django Project error (solved)

Gary Roach gary719_list1 at verizon.net
Sat Aug 1 04:33:39 CEST 2015


On 07/30/2015 11:15 PM, dieter wrote:
> Gary Roach <gary719_list1 at verizon.net> writes:
>> Being new to Django and Python, I have two projects setup side by
>> side, each in it's own virtualenv wrapper.
>> The twr_project is running Django 1.7, python 2.7 and is set up to
>> duplicate the 'Tango With Rango' tutorial.
>> The archivedb project is running Django 1.8, python 2.7 and is my
>> actual project.
> As this is more a "Django" (than a general "Python") question,
> you might get better help in a "Django" mailing list/support forum.
Actually you are dead correct on that.
>
>
> Your "subject" indicates that you likely see (somewhere)
> the "Django" error message "Improper Django Project error".
> Likely, you have corrupted you "Django" project setup.
> Read about how "Django" projects must look like and fix your setup.
The real problem was that the settings.py files for Django 1.7 and 1.8 
have some very significant differences with the format of the TEMPLATES 
= [] tuple. So the  problem's solved --- sort of .
>> I am using Ninja-IDE as my IDE. I like it a lot.
>>
>> At this point both projects are essentially identical with the
>> exception of name changes. The twr project work down to the first
>> template inclusion ( index.html ). The archivedb project refuses to
>> find the home.html template file. The system layout is exactly the
>> same.
>>
>> I wiped the home.html file and attempted to re-install it but my IDE
>> gave the following error window:
>>
>>> Sorry, either settings file or virtualenv are missingthese are
>>> required for Django Plugin to work in thepresent version, we are
>>> working on fixing this.
>>>
>> I have virtualenv installed and active and the settings file is
>> present.
> You should ask this question on a "Ninja-IDE" mailing list/support forum.
Ninja_IDE is just reporting an apparent problem. The real problem is 
that the browser can't find the file. A Django problem.
>



More information about the Python-list mailing list