Installation Successful, but pythonw and idle doesn't function

Terry Reedy tjreedy at udel.edu
Thu Aug 6 03:07:00 CEST 2015


On 8/5/2015 12:12 PM, Rick Smith wrote:
>
> I was able to install various versions of Python (3.5.0b4 32bit being
> the most recent) multiple times (uninstalling in between) and they
> worked ("python --version" at the command line worked).
>
> However pythonw.exe did not and does not work. I was simply returned to
> the command prompt, without ANY interaction or error.

C:\Programs\Python35>pythonw

C:\Programs\Python35>

Normal behavior.

Try
 > python -m idlelib
or, if that does not start 3.5,
 > py -3.5 -m idlelib
and you should either see Idle or an error message

If Idle is starting but not connecting, as you seems to say, there there 
is a problems with your network socket configuration or another program. 
  Adding -n at the end of the command line will will bypass that, though 
you could have other problems in certain situations.

Please see my Who uses IDLE? thread.

-- 
Terry Jan Reedy



More information about the Python-list mailing list