Linux users: please run gui tests

Chris Angelico rosuav at gmail.com
Fri Aug 7 04:20:33 CEST 2015


On Fri, Aug 7, 2015 at 12:07 PM, Terry Reedy <tjreedy at udel.edu> wrote:
> I would appreciate it if some people could run the linux version of
> py -3.4 -m test -ugui test_tk test_ttk_guionly test_idle
> (or 3.5).  I guess this means 'python3 for the executable.
>
> and report here python version, linux system, and result.
> Alteration of environment and locale is a known issue, skip that.

A boatload of windows flicker during the test, which wouldn't surprise
me if they weren't all empty, but I suppose it knows what it's doing.
Toward the end of the test, there are a couple of beeps.

rosuav at sikorsky:~$ python3 -V
Python 3.6.0a0
rosuav at sikorsky:~$ python3 -m test -ugui test_tk test_ttk_guionly test_idle
[1/3] test_tk
[2/3] test_ttk_guionly
[3/3] test_idle
All 3 tests OK.
rosuav at sikorsky:~$ python3.5 -V
Python 3.5.0b1+
rosuav at sikorsky:~$ python3.5 -m test -ugui test_tk test_ttk_guionly test_idle
[1/3] test_tk
[2/3] test_ttk_guionly
[3/3] test_idle
All 3 tests OK.
rosuav at sikorsky:~$ python3.4 -V
Python 3.4.2
rosuav at sikorsky:~$ python3.4 -m test -ugui test_tk test_ttk_guionly test_idle
/usr/bin/python3.4: No module named test.__main__; 'test' is a package
and cannot be directly executed
rosuav at sikorsky:~$ uname -a
Linux sikorsky 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt9-3~deb8u1
(2015-04-24) x86_64 GNU/Linux

The 3.4 is my system Python (Debian Wheezy), and
/usr/lib/python3.4/test doesn't have much in it, so I'm guessing tests
weren't installed.

ChrisA


More information about the Python-list mailing list