"no module named kivy" import error in ubuntu 14.04

shiva upreti katewinslet626 at gmail.com
Sun Aug 16 21:16:53 CEST 2015


Hi
I am new to linux. I tried various things in attempt to install kivy. I installed python 2.7.10 (I think python3 was already installed in ubuntu 14.04). Then i downloaded kivy from https://pypi.python.org/packages/source/K/Kivy/Kivy-1.9.0.tar.gz, extracted it and tried to execute "python setup.py" inside the kivy folder. But it showed the error "no module named cython". Then I tried installing cython, it installed successfully but the command "python setup.py" still gave the error "no module named cython".
Finally I installed kivy using instructions on this video: https://www.youtube.com/watch?v=mypVFCIIZtw. Now when i try to run the following commands:

"$ cd <path to kivy-examples> (I used the actual path, i.e., "/usr/share/kivy-examples")
 $ cd demo/touchtracer
 $ python main.py"
I am still getting the error:"ImportError: No module named kivy".

Any help will be highly appreciated.
Thanks.


More information about the Python-list mailing list