"no module named kivy" import error in ubuntu 14.04

rurpy at yahoo.com rurpy at yahoo.com
Mon Aug 17 05:19:49 CEST 2015


On Sunday, August 16, 2015 at 8:00:14 PM UTC-6, Chris Angelico wrote:
> On Mon, Aug 17, 2015 at 5:16 AM, shiva upreti <katewinslet626 at gmail.com> wrote:
> > I am new to linux. I tried various things in attempt to install kivy. I installed python 2.7.10 (I think python3 was already installed in ubuntu 14.04). Then i downloaded kivy from https://pypi.python.org/packages/source/K/Kivy/Kivy-1.9.0.tar.gz, extracted it and tried to execute "python setup.py" inside the kivy folder.
> 
>[...] 
> use pip (maybe inside a virtualenv). It'll chug for a while and
> then give you what you need.

Umm, actually no...

| ~# pip3 install kivy
| Downloading/unpacking kivy
|   Downloading Kivy-1.9.0.tar.gz (16.2MB): 16.2MB downloaded
|   Running setup.py (path:/tmp/pip-build-m40337r5/kivy/setup.py) egg_info for package kivy
|     Traceback (most recent call last):
|       File "<string>", line 17, in <module>
|       File "/tmp/pip-build-m40337r5/kivy/setup.py", line 173, in <module>
|         from Cython.Distutils import build_ext
|    ImportError: No module named 'Cython'    
|     Cython is missing, its required for compiling kivy !
    
(on Fedora-21 where no kivy repo package is available)


More information about the Python-list mailing list