Having no luck installing Twisted 15.3.0

Skip Montanaro skip.montanaro at gmail.com
Fri Aug 28 19:10:23 CEST 2015


On Fri, Aug 28, 2015 at 12:01 PM, Skip Montanaro
<skip.montanaro at gmail.com> wrote:
> One of our users needs Twisted. I built and installed 15.3.0. When I
> tried to import it, it complained:
>
> ImportError Twisted requires zope.interface 3.6.0 or later.
>
> So I downloaded, built and installed the latest version of
> zope.interface (4.1.2). Still it complains. So I tried 3.7.0. Same
> old, same old. The I installed precisely 3.6.0. Still it complains
> that I need 3.6.0. Looking at the INSTALL file for Twisted, I can't
> see anything else which would be absolutely required to import it.

*sigh* never mind. It's TWW's fault. They install an older version of
zope.interface (3.3.0), then smash sys.path together in such a way
that their packages *always* appear toward the front of the list. The
only way to "override" their stuff is to delete it or move it out of
the way.

Skip


More information about the Python-list mailing list