Having no luck installing Twisted 15.3.0

Skip Montanaro skip.montanaro at gmail.com
Fri Aug 28 20:07:33 CEST 2015


> I've seen this.
>
> You used pip to install zope.interface, right?
> pip installed the thing someplace like:
> /usr/local/lib/python2.7/dist-packages/zope
>
> You want to find it in /usr/share/pyshared/zope/interface/
>
> Solution, make a link.

Alas... I don't think so. The zope.interface stuff is getting
installed in the proper location for our Python installation, however
the necessary __init__.py file isn't being created. We have our own
internal packaging system (why not? everyone else doesn, right?). This
requires me to first install the package in an isolated location. In
this case, I chose /var/tmp/python27_zope_interface-3.7.0. From there,
we add an info file, then package up that directory as a gzip'd tar
file. That tar files is ultimately what gets expanded on machines
around the company. Unfortunately, you can see the problem:

blade% cd /var/tmp/python27_zope_interface-3.7.0/
blade% ls -l lib/python2.7/site-packages/zope
total 4
drwxrwxr-x 4 skipm snake 4096 Aug 28 12:56 interface

What??? No __init__.py file, which is problematic considering I'm
using Python 2.x. There is an __init__.py in .../zope/interface. There
is also an __init__.py file in the build/lib.linux.../zope directory,
so the build step created it. The install step just didn't copy it.
After manually copying and compiling the missing file, then installing
the resulting package, I am able to import twisted...

Skip


More information about the Python-list mailing list