[ANN] EasyGUI_Qt version 0.9

wxjmfauth at gmail.com wxjmfauth at gmail.com
Thu Jan 1 11:39:42 CET 2015


Le mercredi 31 décembre 2014 23:24:50 UTC+1, André Roberge a écrit :
> EasyGUI_Qt version 0.9 has been released.  This is the first announcement about EasyGUI_Qt on this list.
> 
> Like the original EasyGUI (which used Tkinter), 
> EasyGUI_Qt seeks to provide simple GUI widgets
> that can be called in a procedural program. 
> 
> EasyGUI_Qt is NOT event-driven: all GUI interactions are invoked by simple function calls.
> 
> The archetype is get_string(message)
> which pops a box whose purpose is exactly the same as Python's input(prompt),
> that is, present the user with a question/prompt, have the user enter an
> answer, and return the provided answer as a string.  Thus
> easygui_qt.get_string() can be used as a drop-in replacement for
> input().
> 
> Similarly, instead of using a print() function to display a message,
> show_message() is used which pops a message window.
> 
> EasyGUI_Qt requires PyQt4 and is really targeted for Python 3.3+ - although it can work (possibly with some unicode problems ...) using Python 2.7.
> 
> More information can be found at 
> http://easygui-qt.readthedocs.org/en/latest/index.html
> 
> Feedback is most welcome, including reporting bugs to 
> https://github.com/aroberge/easygui_qt/issues
> 
> Happy 2015 everyone,
> 
> André Roberge

If it works like eric6, I quickly tested yesterday
morning, it will not work.

jmf



More information about the Python-list mailing list