Help running python tests on MIPS

Ramesh rramesh1 at
Sun Jan 11 04:07:58 CET 2015

I am new to python.

I downloaded python 2.7.8 tarball, successfully cross compiled it, to make sure that the subsystems are correctly built, I tried running the python test scripts on the MIPS based target board. I hit the below error while I do so,

# /opt/Python-2.7.8/bin/python2.7 /opt/Python-2.7.8/lib/python2.7/test/test___al
Traceback (most recent call last):
  File "/opt/Python-2.7.8/lib/python2.7/test/", line 3, in <module>
    import unittest
  File "/opt/Python-2.7.8/lib/python2.7/unittest/", line 58, in <module>
    from .result import TestResult
  File "/opt/Python-2.7.8/lib/python2.7/unittest/", line 9, in <module>
    from . import util
  File "/opt/Python-2.7.8/lib/python2.7/unittest/", line 2, in <module>
    from collections import namedtuple, OrderedDict
  File "/opt/Python-2.7.8/lib/python2.7/", line 8, in <module>
    from _collections import deque, defaultdict
ImportError: No module named _collections

I tried setting PATH & PYTHONPATH, but it doesn't seem to fix the issue. Can someone please advice on what possibly is causing this problem / how to fix this?


More information about the Python-list mailing list