Python is DOOMED! Again!

Chris Angelico rosuav at gmail.com
Tue Jan 27 21:40:28 CET 2015


On Wed, Jan 28, 2015 at 4:59 AM, Mario Figueiredo <marfig at gmail.com> wrote:
> An optional feature says nothing of its requirements. The requirements
> for PEP 484 are heavy. Not only will they force an update to the
> interpreter, but will also force many users to reformate their function
> headers in order for them to become bareable to the eye. In fact, no
> longer will you look at function definitions like you did before.

What updates are needed to the interpreter?

https://www.python.org/dev/peps/pep-3107/

Already happened, long ago.

ChrisA



More information about the Python-list mailing list