Python 3.3 couldnt find its libraries.

Steven D'Aprano steve at pearwood.info
Wed Sep 9 19:36:32 CEST 2015


On Wed, 9 Sep 2015 07:37 pm, Φώντας Λαδοπρακόπουλος wrote:

[...]
> [root at superhost ~]# /opt/rh/python33/root/usr/bin/python -V
> /opt/rh/python33/root/usr/bin/python: error while loading shared
> libraries: libpython3.3m.so.1.0: cannot open shared object file: No such
> file or directory

Again?

Nikos, this looks like exactly the same error you got back in April, in the
thread with subject line "Question Installing latest Python". The date was
around 29 Apr 2015, possibly a couple of days either side. I suggest you go
back and read the replies to that.


If this is the same problem, then I think these were the steps you followed
last time.


Try running this as a regular user:

python3 -c "import sys; print(sys.executable)"


Does it work? If not, run this as the root user:

ldconfig

That will tell your system to cache any shared libraries it knows about. yum
is supposed to do that for you, but perhaps it didn't. Now try running the
python3 test above. Does it work? Then the problem is solved and you can
stop reading.


If you get the same error, then run this as root:

find /opt -name libpython3.3m.so.1.0

If it returns a single result, that's good. If it returns no results, try
this instead:

find / -name libpython3.3m.so.1.0 2> /dev/null

It may take a while: it's going to search your entire hard drive. Hopefully
that will return a single result: let's say it returns

/this/that/libpython3.3m.so.1.0

then you need to edit /etc/ld.so.conf and add this line to the end:

/this/that


Save your changes, run ldconfig again, and hopefully python3 will now work.



-- 
Steven



More information about the Python-list mailing list