Can't use Python Launcher on Windows after update to 3.5

Mark Lawrence breamoreboy at yahoo.co.uk
Thu Sep 10 17:56:37 CEST 2015


On 10/09/2015 11:20, Tim Golden wrote:
> On 10/09/2015 00:52, Mark Lawrence wrote:
>> I've installed 3.5 for all users so it's in C:\Program Files
>>
>> From
>> https://docs.python.org/3.5/using/windows.html#from-the-command-line it
>> says "System-wide installations of Python 3.3 and later will put the
>> launcher on your PATH. The launcher is compatible with all available
>> versions of Python, so it does not matter which version is installed. To
>> check that the launcher is available, execute the following command in
>> Command Prompt:", but:-
>>
>> C:\Users\Mark\Documents\MyPython>py -3.4
>> 'py' is not recognized as an internal or external command,
>> operable program or batch file.
>>
>> Further running ftype shows nothing for Python, assoc just gives this
>> .pyproj=VisualStudio.Launcher.pyproj.14.0.  Surely this is wrong?
>>
>> Before I go to the bug tracker to raise an issue could somebody please
>> confirm what I'm seeing, thanks.
>>
>
> Well I've just installed 64-bit 3.5.0rc4 via the web installer (ie this:
> https://www.python.org/ftp/python/3.5.0/python-3.5.0rc4-amd64-webinstall.exe)
> onto a machine with 64-bit 3.4.2 already installed. I went for the
> default install.
>
> It all seems to be ok and py -3.4 --version gives  me "Python 3.4.2" as
> expected. assoc/ftype both look ok. c:\windows\py.exe has the versions &
> dates I expect.
>
> TJG
>

So I ran the 64-bit 3.5.0rc4 via the web installer and still no joy. 
Ran repair with same and it's business as usual.  I'm not that bothered, 
it's here for the record should anybody else come searching, so chalk it 
up to experience and move on.  Thanks anyway :)

-- 
My fellow Pythonistas, ask not what our language can do for you, ask
what you can do for our language.

Mark Lawrence



More information about the Python-list mailing list