Problem configuring apache to run python cgi on Ubuntu 14.04

alister alister.nospam.ware at ntlworld.com
Mon Sep 21 22:29:33 CEST 2015


On Mon, 21 Sep 2015 12:51:09 -0700, tropical.dude.net wrote:

> On Monday, September 21, 2015 at 9:47:33 PM UTC+2, tropical... at gmail.com
> wrote:
>> On Monday, September 21, 2015 at 9:41:29 PM UTC+2, John Gordon wrote:
>> > In <44e870a7-9567-40ba-8a65-d6b52a8c5d25 at googlegroups.com>
>> > tropical.dude.net at gmail.com writes:
>> > 
>> > > print("Content-Type: text/html;charset=utf-8")
>> > > print("Hello World!")
>> > 
>> > As I recall, you must have a blank line between the headers and the
>> > content.
>> > 
>> > But that may or may not be your problem, as you haven't told us
>> > exactly what is going wrong.
>> > 
>> > --
>> > John Gordon                   A is for Amy, who fell down the stairs
>> > gordon at panix.com              B is for Basil, assaulted by bears
>> >                                 -- Edward Gorey, "The Gashlycrumb
>> >                                 Tinies"
>> 
>> I am new to Ubuntu, is there a command so I can find out what the
>> problem is?
> 
> The only error I can see right now is forbedden, you don't have
> permission to access /index.py on this server.

this is not a linux permissions error it is an error with the apache 
configuration you need to check roe acache config files
(you may also want to investigate WSGI as CGI is outdated) 



-- 
Perfection is acheived only on the point of collapse.
- C. N. Parkinson


More information about the Python-list mailing list