Can't find setuptools

Alonso López alonso_oso at hotmail.com
Sat Dec 10 16:11:57 EST 2016


Hi, I'm trying to install the package py-webrtcvad (github.com/wiseman/py-webrtcvad) and running into problems. Here's a summary of what I've tried so far:


·        Installed Python 3.5 and set up the Windows path environment so that it works from any directory.

·        Installed pip for Python.

·        Tried to install the package with python -m pip install webrtcvad, but it failed, returning the error "Unable to find vcvarsall.bat".

·        I found a blog that seems to deal with the problem vcvarsall.bat problem: blogs.msdn.microsoft.com/pythonengineering/2016/04/11/unable-to-find-vcvarsall-bat/. Following the directions of that blog:

o   I installed Visual C++ Build Tools 2015. I tried running the program again straight away (without updating setuptools) and I received a lot of error messages which I didn't write down.

o   Following the directions in https://pypi.python.org/pypi/setuptools I removed the version of setuptools that came with my Python installation (v20), and installed the latest version (v30). This time the error message was "ImportError: No module named 'pip.utils.setuptools_build'".

o   Asked for assistance in the Python official chat. They made three suggestions:

§  Updating pip with python -m pip install --upgrade pip. Didn't work. Again, the error "ImportError: No module named 'pip.utils.setuptools_build'".

§  Reinstalling Visual C++ Build Tools 2015. No difference, same error again.

§  Reinstalling Python itself. The Python installer offers three choices: Repair, modify and uninstall.

·        Repair: Didn't work. Same error.

·        Modify: Doesn't look like it offers useful modifications for this.

·        Uninstall: Uninstalled and reinstalled. Still the same error.
I'm out of ideas. Can you help me?

Thank you,

Alonso López



More information about the Python-list mailing list