ImportError: The ``fake-factory`` package is now called ``Faker``.

Uri Even-Chen uri at speedy.net
Thu Dec 22 09:12:17 EST 2016


Thank you, I found out that pip freeze returned more packages than what we
had in our requirements.txt file, so I upgraded them and added them to the
file. I also upgraded to Faker==0.7.7

Uri.

*Uri Even-Chen*
[image: photo] Phone: +972-54-3995700
Email: uri at speedy.net
Website: http://www.speedysoftware.com/uri/en/
<http://www.facebook.com/urievenchen>  <http://plus.google.com/+urievenchen>
  <http://www.linkedin.com/in/urievenchen>  <http://github.com/urievenchen>
<http://twitter.com/urievenchen>

On Tue, Dec 20, 2016 at 7:11 PM, William Mayor <mail at williammayor.co.uk>
wrote:

> I came across this error this morning.
>
> In my case I was running a script that did this: “pip install fake-factory”
>
> The install worked properly but then I couldn’t import the library (with
> the same error message as you).
>
> I had to update the pip install command to say “pip install Faker” and
> then everything worked as before.
>
> The authors appear to have forced a name change: https://github.com/
> joke2k/faker/blob/fake-factory/faker/__init__.py
>
> I’ve just checked and if you pin your requirements (e.g. pip install
> fake-factory==0.7.4) then it still works.
>
>
> On 20 Dec 2016, at 16:57, Uri Even-Chen <uri at speedy.net> wrote:
>
> Hi, we get this error with Python 3.4 and 3.5:
> https://travis-ci.org/urievenchen/speedy-net/jobs/185497863
>
>
> ----------------------------------------------------------------------
>
> ImportError: Failed to import test module:
> speedy.net.accounts.tests.test_factories
>
> Traceback (most recent call last):
>
>  File "/opt/python/3.5.2/lib/python3.5/unittest/loader.py", line 428,
> in _find_test_path
>
>    module = self._get_module_from_name(name)
>
>  File "/opt/python/3.5.2/lib/python3.5/unittest/loader.py", line 369,
> in _get_module_from_name
>
>    __import__(name)
>
>  File "/home/travis/build/urievenchen/speedy-net/speedy/
> net/accounts/tests/test_factories.py",
> line 4, in <module>
>
>    import factory
>
>  File "/home/travis/virtualenv/python3.5.2/lib/python3.5/
> site-packages/factory/__init__.py",
> line 46, in <module>
>
>    from .faker import Faker
>
>  File "/home/travis/virtualenv/python3.5.2/lib/python3.5/
> site-packages/factory/faker.py",
> line 41, in <module>
>
>    import faker
>
>  File "/home/travis/virtualenv/python3.5.2/lib/python3.5/
> site-packages/faker/__init__.py",
> line 7, in <module>
>
>    raise ImportError(error)
>
> ImportError: The ``fake-factory`` package is now called ``Faker``.
>
> Please update your requirements.
>
>
> What is the problem? We didn't update our requirements recently.
>
> Thanks,
> Uri.
>
> *Uri Even-Chen*
> [image: photo] Phone: +972-54-3995700 <+972%2054-399-5700>
> Email: uri at speedy.net
> Website: http://www.speedysoftware.com/uri/en/
> <http://www.facebook.com/urievenchen>  <http://plus.google.com/+
> urievenchen>
>  <http://www.linkedin.com/in/urievenchen>  <http://github.com/urievenchen>
> <http://twitter.com/urievenchen>
> --
> https://mail.python.org/mailman/listinfo/python-list
>
>
>


More information about the Python-list mailing list