setup failed

Mark Summerfield list at qtrac.plus.com
Mon Feb 8 06:02:01 EST 2016


On Monday, February 8, 2016 at 10:50:19 AM UTC, Mark Summerfield wrote:
> If you need 32-bit Python on Windows my advice is to install 3.4. If you need 32-bit and 64-bit Python on Windows, then I think it will only work with 3.4 (or older), but not with 3.5's new installer.
> 
> I have tried installing 3.5.0 and 3.5.1 on several machines both 32- and 64-bit Windows. The 32-bit installer either doesn't work at all or won't work with two third-party packages I use: APSW and PyWin32. The 64-bit installer does seem to work on 64-bit machines, but in my particular case I need both 32- and 64-bit versions so use Python 3.4. Hopefully the problem will be fixed before 3.4's end of life:-)

Ooops, of course you're already using the 64-bit installer. My advice is use Python 3.4 if you need to work on Windows: unlike the 3.5 installer I've never encountered a problem with the 3.4 (or 3.3) installers.


More information about the Python-list mailing list