Cygwin and Python3

Fillmore fillmore_remove at hotmail.com
Tue Feb 9 17:36:20 EST 2016


On 2/9/2016 4:47 PM, Fillmore wrote:
> On 2/9/2016 3:30 PM, alvin.hacopian at gmail.com wrote:
>
>>
>> When you run the cygwin installer you have the option of installing 2.7
>  > and 3.2.5, by default it will install 2.7 and 3.2 together.
>  > After running the installer run whereis python and use the alternatives
>  > to change it or use python3 instead of python #!/usr/bin/python3
>>
>> Hope this helps.
>
>
> I see. I was trying to do it the Perl way. I simply linked the
> strawberry perl.exe from cygwin environemnt and it replaced the built in
> perl that sucked.
> OK. Backtrack. I'll try with a purely cygwin solution...
>
> Thank you
>
>

$ python --version
Python 2.7.10

$ python3 --version
Python 3.4.3

Thank you, Alvin



More information about the Python-list mailing list