pylint -> ImportError: No module named lazy_object_proxy

Michael Ströder michael at stroeder.com
Wed Feb 10 12:25:18 EST 2016


Peter Otten wrote:
> Michael Ströder wrote:
> 
>> HI!
>>
>> Hmm, I've used pylint before but my current installation gives me an
>> ImportError:
>>
>> $ pylint
>> [..]
>> ImportError: No module named lazy_object_proxy
>>
>> Can anybody here give me a hint what's missing?
>> six, astroid and tk modules are installed.
>> Any more dependencies?
> 
> How about the dependencies' dependencies? Grepping through the astroid 
> source finds
> 
> ../astroid/__pkginfo__.py:install_requires = ['six', 'lazy_object_proxy', 
> 'wrapt']

Ah, overlooked this. Thanks.

> But doesn't pip care of these?

Yes, likely, but...

I've added new openSUSE packages python-lazy_object_proxy and python-wrapt which
hopefully will appear in devel:languages:python repo soon.

Ciao, Michael.



More information about the Python-list mailing list