asyncmongo + python 3: No module named 'errors'

Nagy László Zsolt gandalf at shopzeus.com
Thu Feb 25 03:08:15 EST 2016


ayncmongo requirements are "pymongo" and "tornado".

I have a fresh installation of Python 3.5, pymongo 3.2 and tornado 4.3,
but I cannot import asyncmongo.

Tracelog below.


P:\WinPython-64bit-3.5.1.2\python-3.5.1.amd64>python
Python 3.5.1 (v3.5.1:37a07cee5969, Dec  6 2015, 01:54:25) [MSC v.1900 64
bit (AMD64)] on win32
Type "help", "copyright", "credits" or "license" for more information.
>>> import pymongo
>>> pymongo.version
'3.2'
>>> import tornado
>>> tornado.version
'4.3'
>>> import asyncmongo
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File
"P:\WinPython-64bit-3.5.1.2\python-3.5.1.amd64\lib\site-packages\asyncmongo\__init__.py",
line 37, in <module>
    from errors import (Error, InterfaceError, AuthenticationError,
DatabaseError, RSConnectionError,
ImportError: No module named 'errors'
>>>
























More information about the Python-list mailing list