"Edit with IDLE" doesn't work any more ?

Yip, Kin kinyip at bnl.gov
Fri Apr 28 08:04:41 EDT 2017


Hi,

I'm relatively new with Python3 in Windows 7.  I'm using now Python 3.6.1.

Suddenly right-clicking on a .py file  and choose "Edit with IDLE" just doesn't work.

I've tried to do :

"c:\program files\python36\pythonw.exe"   -m idlelib    mypythoncodes.py


the IDLE editor just doesn't come up.    But if I start the IDLE Shell and then "Open File", the editor is there and
works normally.

I've tried to uninstall "python launcher" and then repair or modify  "python3.6 " in Control Panel/Program and Features.   Nothing works ...

Any help ?  I show you my Windows registry at the bottom of this email.

Kin

PS: My registry :

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\Python.File\shell]

[HKEY_CLASSES_ROOT\Python.File\shell\editwithidle]
"MUIVerb"="&Edit with IDLE"
"Subcommands"=""

[HKEY_CLASSES_ROOT\Python.File\shell\editwithidle\shell]

[HKEY_CLASSES_ROOT\Python.File\shell\editwithidle\shell\edit36]
"MUIVerb"="Edit with IDLE 3.6 (64-bit)"

[HKEY_CLASSES_ROOT\Python.File\shell\editwithidle\shell\edit36\command]
@="\"C:\\Program Files\\Python36\\pythonw.exe\" -m idlelib \"%L\" %*"

[HKEY_CLASSES_ROOT\Python.File\shell\open]

[HKEY_CLASSES_ROOT\Python.File\shell\open\command]
@="\"C:\\WINDOWS\\py.exe\" \"%L\" %*"

[HKEY_CLASSES_ROOT\Python.File\shell\Run]

[HKEY_CLASSES_ROOT\Python.File\shell\Run\command]
@="\"C:\\Windows\\py.exe\" \"%1\" %*"

[HKEY_CLASSES_ROOT\Python.File\shell\runas]

[HKEY_CLASSES_ROOT\Python.File\shell\runas\command]
@="\"C:\\Windows\\py.exe\" \"%1\" %*"



More information about the Python-list mailing list