pip install -r requirements.txt fails with Python 3.6 on Windows 10

INADA Naoki songofacandy at gmail.com
Tue Jan 3 11:35:40 EST 2017


Pillow 3.4.2 provides binary wheel for Python 3.5, but not for 3.6.

So your pip can just install wheel on Python 3.5, but it is required to build
on Python 3.6.  And your machine doesn't have zlib which is required
to build Pillow.

Easiest solution may just update your requirements to Pillow==4.0.0.
Pillow 4.0.0 provides binary wheel for Python 3.6, from 2017-01-02.
https://pypi.python.org/pypi/Pillow/4.0.0


On Tue, Jan 3, 2017 at 10:19 PM, Uri Even-Chen <uri at speedy.net> wrote:
> (.venv) C:\Uri\Speedy Net\Git\speedy-net [public]>pip install -r
> requirements.txt
> Requirement already satisfied: Django==1.10.4 in c:\uri\speedy
> net\git\speedy-net [public]\.venv\lib\site-packages (from -r
> requirements.txt (line 2))
> Requirement already satisfied: django-crispy-forms==1.6.1 in c:\uri\speedy
> net\git\speedy-net [public]\.venv\lib\site-packages (from -r
> requirements.txt (line 3))
> Requirement already satisfied: django-debug-toolbar==1.6 in c:\uri\speedy
> net\git\speedy-net [public]\.venv\lib\site-packages (from -r
> requirements.txt (line 4))
> Requirement already satisfied: django-environ==0.4.1 in c:\uri\speedy
> net\git\speedy-net [public]\.venv\lib\site-packages (from -r
> requirements.txt (line 5))
> Requirement already satisfied: django-friendship==1.5.0 in c:\uri\speedy
> net\git\speedy-net [public]\.venv\lib\site-packages (from -r
> requirements.txt (line 6))
> Requirement already satisfied: django-modeltranslation==0.12 in
> c:\uri\speedy net\git\speedy-net [public]\.venv\lib\site-packages (from -r
> requirements.txt (line 7))
> Requirement already satisfied: factory-boy==2.8.1 in c:\uri\speedy
> net\git\speedy-net [public]\.venv\lib\site-packages (from -r
> requirements.txt (line 8))
> Requirement already satisfied: Faker==0.7.7 in c:\uri\speedy
> net\git\speedy-net [public]\.venv\lib\site-packages (from -r
> requirements.txt (line 9))
> Collecting Pillow==3.4.2 (from -r requirements.txt (line 10))
>   Using cached Pillow-3.4.2.tar.gz
> Requirement already satisfied: python-dateutil==2.6.0 in c:\uri\speedy
> net\git\speedy-net [public]\.venv\lib\site-packages (from -r
> requirements.txt (line 11))
> Collecting rules==1.2 (from -r requirements.txt (line 12))
>   Using cached rules-1.2.tar.gz
> Requirement already satisfied: six==1.10.0 in c:\uri\speedy
> net\git\speedy-net [public]\.venv\lib\site-packages (from -r
> requirements.txt (line 13))
> Collecting sorl-thumbnail==12.4a1 (from -r requirements.txt (line 14))
>   Using cached sorl_thumbnail-12.4a1-py2.py3-none-any.whl
> Requirement already satisfied: sqlparse==0.2.2 in c:\uri\speedy
> net\git\speedy-net [public]\.venv\lib\site-packages (from -r
> requirements.txt (line 15))
> Installing collected packages: Pillow, rules, sorl-thumbnail
>   Running setup.py install for Pillow ... error
>     Complete output from command "c:\uri\speedy net\git\speedy-net
> [public]\.venv\scripts\python.exe" -u -c "import setuptools,
> tokenize;__file__='C:\\Users\\Uri\\AppData\\Local\\Temp\\pip-build-3dj7ngjs\\Pillow\\setup.py';f=getattr(tokenize,
> 'open', open)(__file__);code=f.read().replace('\r\n',
> '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record
> C:\Users\Uri\AppData\Local\Temp\pip-1464cmd1-record\install-record.txt
> --single-version-externally-managed --compile --install-headers
> "c:\uri\speedy net\git\speedy-net
> [public]\.venv\include\site\python3.6\Pillow":
>     Single threaded build for windows
>     running install
>     running build
>     running build_py
>     creating build
>     creating build\lib.win32-3.6
>     creating build\lib.win32-3.6\PIL
>     copying PIL\BdfFontFile.py -> build\lib.win32-3.6\PIL
>     copying PIL\BmpImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\BufrStubImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\ContainerIO.py -> build\lib.win32-3.6\PIL
>     copying PIL\CurImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\DcxImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\DdsImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\EpsImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\ExifTags.py -> build\lib.win32-3.6\PIL
>     copying PIL\features.py -> build\lib.win32-3.6\PIL
>     copying PIL\FitsStubImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\FliImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\FontFile.py -> build\lib.win32-3.6\PIL
>     copying PIL\FpxImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\FtexImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\GbrImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\GdImageFile.py -> build\lib.win32-3.6\PIL
>     copying PIL\GifImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\GimpGradientFile.py -> build\lib.win32-3.6\PIL
>     copying PIL\GimpPaletteFile.py -> build\lib.win32-3.6\PIL
>     copying PIL\GribStubImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\Hdf5StubImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\IcnsImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\IcoImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\Image.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageChops.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageCms.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageColor.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageDraw.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageDraw2.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageEnhance.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageFile.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageFilter.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageFont.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageGrab.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageMath.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageMode.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageMorph.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageOps.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImagePalette.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImagePath.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageQt.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageSequence.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageShow.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageStat.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageTk.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageTransform.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImageWin.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\ImtImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\IptcImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\Jpeg2KImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\JpegImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\JpegPresets.py -> build\lib.win32-3.6\PIL
>     copying PIL\McIdasImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\MicImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\MpegImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\MpoImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\MspImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\OleFileIO.py -> build\lib.win32-3.6\PIL
>     copying PIL\PaletteFile.py -> build\lib.win32-3.6\PIL
>     copying PIL\PalmImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\PcdImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\PcfFontFile.py -> build\lib.win32-3.6\PIL
>     copying PIL\PcxImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\PdfImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\PixarImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\PngImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\PpmImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\PsdImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\PSDraw.py -> build\lib.win32-3.6\PIL
>     copying PIL\PyAccess.py -> build\lib.win32-3.6\PIL
>     copying PIL\SgiImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\SpiderImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\SunImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\TarIO.py -> build\lib.win32-3.6\PIL
>     copying PIL\TgaImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\TiffImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\TiffTags.py -> build\lib.win32-3.6\PIL
>     copying PIL\WalImageFile.py -> build\lib.win32-3.6\PIL
>     copying PIL\WebPImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\WmfImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\XbmImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\XpmImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\XVThumbImagePlugin.py -> build\lib.win32-3.6\PIL
>     copying PIL\_binary.py -> build\lib.win32-3.6\PIL
>     copying PIL\_tkinter_finder.py -> build\lib.win32-3.6\PIL
>     copying PIL\_util.py -> build\lib.win32-3.6\PIL
>     copying PIL\__init__.py -> build\lib.win32-3.6\PIL
>     running egg_info
>     writing Pillow.egg-info\PKG-INFO
>     writing dependency_links to Pillow.egg-info\dependency_links.txt
>     writing top-level names to Pillow.egg-info\top_level.txt
>     warning: manifest_maker: standard file '-c' not found
>
>     reading manifest file 'Pillow.egg-info\SOURCES.txt'
>     reading manifest template 'MANIFEST.in'
>     warning: no files found matching '*.sh'
>     no previously-included directories found matching 'docs\_static'
>     warning: no previously-included files found matching '.coveragerc'
>     warning: no previously-included files found matching '.editorconfig'
>     warning: no previously-included files found matching '.landscape.yaml'
>     warning: no previously-included files found matching 'appveyor.yml'
>     warning: no previously-included files found matching 'build_children.sh'
>     warning: no previously-included files found matching 'tox.ini'
>     warning: no previously-included files matching '.git*' found anywhere
> in distribution
>     warning: no previously-included files matching '*.pyc' found anywhere
> in distribution
>     warning: no previously-included files matching '*.so' found anywhere in
> distribution
>     writing manifest file 'Pillow.egg-info\SOURCES.txt'
>     copying PIL\OleFileIO-README.md -> build\lib.win32-3.6\PIL
>     running build_ext
>     Traceback (most recent call last):
>       File "<string>", line 1, in <module>
>       File
> "C:\Users\Uri\AppData\Local\Temp\pip-build-3dj7ngjs\Pillow\setup.py", line
> 753, in <module>
>         zip_safe=not debug_build(), )
>       File
> "C:\Users\Uri\AppData\Local\Programs\Python\Python36-32\lib\distutils\core.py",
> line 148, in setup
>         dist.run_commands()
>       File
> "C:\Users\Uri\AppData\Local\Programs\Python\Python36-32\lib\distutils\dist.py",
> line 955, in run_commands
>         self.run_command(cmd)
>       File
> "C:\Users\Uri\AppData\Local\Programs\Python\Python36-32\lib\distutils\dist.py",
> line 974, in run_command
>         cmd_obj.run()
>       File "c:\uri\speedy net\git\speedy-net
> [public]\.venv\lib\site-packages\setuptools\command\install.py", line 61,
> in run
>         return orig.install.run(self)
>       File
> "C:\Users\Uri\AppData\Local\Programs\Python\Python36-32\lib\distutils\command\install.py",
> line 545, in run
>         self.run_command('build')
>       File
> "C:\Users\Uri\AppData\Local\Programs\Python\Python36-32\lib\distutils\cmd.py",
> line 313, in run_command
>         self.distribution.run_command(command)
>       File
> "C:\Users\Uri\AppData\Local\Programs\Python\Python36-32\lib\distutils\dist.py",
> line 974, in run_command
>         cmd_obj.run()
>       File
> "C:\Users\Uri\AppData\Local\Programs\Python\Python36-32\lib\distutils\command\build.py",
> line 135, in run
>         self.run_command(cmd_name)
>       File
> "C:\Users\Uri\AppData\Local\Programs\Python\Python36-32\lib\distutils\cmd.py",
> line 313, in run_command
>         self.distribution.run_command(command)
>       File
> "C:\Users\Uri\AppData\Local\Programs\Python\Python36-32\lib\distutils\dist.py",
> line 974, in run_command
>         cmd_obj.run()
>       File
> "C:\Users\Uri\AppData\Local\Programs\Python\Python36-32\lib\distutils\command\build_ext.py",
> line 339, in run
>         self.build_extensions()
>       File
> "C:\Users\Uri\AppData\Local\Temp\pip-build-3dj7ngjs\Pillow\setup.py", line
> 521, in build_extensions
>         ' using --disable-%s, aborting' % (f, f))
>     ValueError: zlib is required unless explicitly disabled using
> --disable-zlib, aborting
>
>     ----------------------------------------
> Command ""c:\uri\speedy net\git\speedy-net
> [public]\.venv\scripts\python.exe" -u -c "import setuptools,
> tokenize;__file__='C:\\Users\\Uri\\AppData\\Local\\Temp\\pip-build-3dj7ngjs\\Pillow\\setup.py';f=getattr(tokenize,
> 'open', open)(__file__);code=f.read().replace('\r\n',
> '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record
> C:\Users\Uri\AppData\Local\Temp\pip-1464cmd1-record\install-record.txt
> --single-version-externally-managed --compile --install-headers
> "c:\uri\speedy net\git\speedy-net
> [public]\.venv\include\site\python3.6\Pillow"" failed with error code 1 in
> C:\Users\Uri\AppData\Local\Temp\pip-build-3dj7ngjs\Pillow\
>
> (.venv) C:\Uri\Speedy Net\Git\speedy-net [public]>pip install -r
> requirements.txt
>
> What is the problem? Our requirements file is here:
> https://github.com/urievenchen/speedy-net/blob/master/requirements.txt
>
> It doesn't fail with Python 3.5.2
>
> *Uri Even-Chen*
> [image: photo] Phone: +972-54-3995700
> Email: uri at speedy.net
> Website: http://www.speedysoftware.com/uri/en/
> <http://www.facebook.com/urievenchen>  <http://plus.google.com/+urievenchen>
>   <http://www.linkedin.com/in/urievenchen>  <http://github.com/urievenchen>
> <http://twitter.com/urievenchen>
> --
> https://mail.python.org/mailman/listinfo/python-list


More information about the Python-list mailing list