Numpy error

Deborah Swanson python at deborahswanson.net
Mon Jan 2 18:57:30 EST 2017


> ImportError:
> /home/conrado/Canopy/appdata/canopy-1.5.5.3123.rh5-x86_64/lib/
> libgfortran.so.3:
> version `GFORTRAN_1.4' not found (required by /lib64/liblapack.so.3)

Looks like you need to install the 'GFORTRAN_1.4' plugin into Canopy. I don't 
know where you'll find it, but Canopy's main website would be a good place to 
start. Or google "GFORTRAN_1.4 Canopy download".


jorge.conrado at cptec.inpe.br wrote, on January 03, 2017 6:45 AM:
>
> Hi,
>
>
> I alredy used Python and now I have the message:
>
> import numpy as np
> Traceback (most recent call last):
>    File "<stdin>", line 1, in <module>
>    File
> "/home/conrado/Enthought/Canopy_64bit/User/lib/python2.7/site-
> packages/numpy-1.8.0-py2.7-linux-x86_64.egg/numpy/__init__.py",
> line 153, in <module>
>      from . import add_newdocs
>    File
> "/home/conrado/Enthought/Canopy_64bit/User/lib/python2.7/site-
> packages/numpy-1.8.0-py2.7-linux-x86_64.egg/numpy/add_newdocs.py",
> line 13, in <module>
>      from numpy.lib import add_newdoc
>    File
> "/home/conrado/Enthought/Canopy_64bit/User/lib/python2.7/site-
> packages/numpy-1.8.0-py2.7-linux-x86_64.egg/numpy/lib/__init__.py",
> line 18, in <module>
>      from .polynomial import *
>    File
> "/home/conrado/Enthought/Canopy_64bit/User/lib/python2.7/site-
> packages/numpy-1.8.0-py2.7-linux-x86_64.egg/numpy/lib/polynomial.py",
> line 19, in <module>
>      from numpy.linalg import eigvals, lstsq, inv
>    File
> "/home/conrado/Enthought/Canopy_64bit/User/lib/python2.7/site-
> packages/numpy-1.8.0-py2.7-linux-x86_64.egg/numpy/linalg/__ini
> t__.py",
> line 50, in <module>
>      from .linalg import *
>    File
> "/home/conrado/Enthought/Canopy_64bit/User/lib/python2.7/site-
> packages/numpy-1.8.0-py2.7-linux-x86_64.egg/numpy/linalg/linalg.py",
> line 29, in <module>
>      from numpy.linalg import lapack_lite, _umath_linalg
> ImportError:
> /home/conrado/Canopy/appdata/canopy-1.5.5.3123.rh5-x86_64/lib/
> libgfortran.so.3:
> version `GFORTRAN_1.4' not found (required by /lib64/liblapack.so.3)
>
>
> I did:  pip istall --user numpy
>
>
> Requirement already satisfied: numpy in
> /home/conrado/Enthought/Canopy_64bit/User/lib/python2.7/site-p
> ackages/numpy-1.8.0-py2.7-linux-x86_64.egg
>
>
> What can I do to solve this message.
>
>
> Thanks,
>
>
> Conrado
> --
> https://mail.python.org/mailman/listinfo/python-list
>



More information about the Python-list mailing list